PowerCADD and Mac OS 10.9 Mavericks

Will PowerCADD Run in Mac OS? X 10.9 Mavericks?

  • PowerCADD version 9 (9.1.3 or newer required)
  • Mac OS X 10.9 Mavericks (10.9.2 or newer recommended)




Background

Any version of PowerCADD version 1 through version 8 will not work with Mac OS X Mavericks (10.9). The only version of PowerCADD approved to run in Mac OS X 10.9 is PowerCADD version 9.1.3 or newer.

If you are experiencing problems with your version PowerCADD not working at all, or being overly problematic (various symptoms might exist) then check your version of PowerCADD and Mac OS X as there is quite possibly a mismatch that is causing the problem.

To find out what version of PowerCADD you are using:

  1. With PowerCADD running, choose PowerCADD menu → PowerCADD Profile
  2. A dialog will open listing the version and build numbers

To find out what version of Mac OS X you are using:

  1. Choose Apple menu → About This Mac. A dialog opens and the version number is listed there.

What To Do

If you are an existing PowerCADD user (any version) there are few different options depending on which version of PowerCADD you currently have. Here's a general breakdown:

Paid Upgrades
Current registered PowerCADD users can upgrade from an earlier version of PowerCADD (e.g. PowerCADD 8 to PowerCADD 9) and should review the information on this page of our website. Please note these are paid upgrades (not free updates). For pricing contact your International Distributor or if you're in the U.S. contact Engineered Software.

Free Updates
To make sure you receive emails and all relevant information on keeping your copy of PowerCADD v9 up to date please make sure you've registered your product. In the United States, contact Engineered Software directly (click here for link XTNL URL). In other countries please contact your regional distributor (click here for link XTNL URL). If you have not received an update notice from Engineered Software (or your regional international distributor) contact them directly from the links previously provided.

In general, it's highly recommended you update your version of PowerCADD 9.x to 9.1.3 before upgrading your current version of Mac OS X to 10.9 Mavericks. If you have already upgraded your copy of Mac OS X to Mavericks before updating your copy of PowerCADD 9 contact technical support at Engineered Software (in the U.S.), or technical support for your international distributor at the links noted earlier. We also have a related article at this link you may find useful.

New PowerCADD Users
If you are buying a new version of PowerCADD (from Engineered Software in the U.S. or an International Distributor), you will receive the latest version with that purchase. However, we encourage all new purchasers to confirm with the respective seller that PowerCADD version 9.1.3 (or newer) it what will be provided on the master install CD. If the version is older than that (i.e. PowerCADD v9.1.0 verses v9.1.3) then please confirm the update process you'll have to follow or have the seller provide the most current version for your new purchase.

We hope that helps
caddpower.com

------
If you found this article or the website in general to be helpful, educational or a time and money saver you can show your support. Thank you ~ Brian (huc) Huculak, Co-founder and Managing Editor, www.caddpower.com - www.powercadduser.com - www.powercadd.guru - www.wildtools.guru

Your rating: None Average: 5 (1 vote)