Layer Color Attributes and Move To Layer Cmd

Issue

When I use Move To Layer (a new feature in PowerCADD), and the destination Layer has a Layer Color Attribute, the relocated object does not adopt the Layer Color.

Affects

PowerCADD v7.00, v7.0.1



Description

The Move To Layer command let's me move objects from one layer to another. However, when the destination layer (layer I'm moving the object(Drunk) to has a layer color, the moved object doesn't adopt the layer color. If I use Cut or Copy and Paste to move the object between layers, the object I Pasted (i.e. Moved) correctly adopts the destination Layer Color.

To See the Condition

In PowerCADD v7, do this:

  1. Create a New Untitled document
  2. Create a new layer, Layer 1. Do not assign any attributes to that layer
  3. Create a new layer, Layer 2 and assign a Layer Color Attribute of red
  4. Draw a Line on Layer 1
  5. Press Control and click on the Line in step 4 and choose Move to Layer 2 from the Contextual menu
  6. Observe: The Line does not adopt the red Layer Color Attribute assigned to Layer 2
  7. This is an incorrect result, the Line should have changed color

To see the correct results use Copy or Cut and Paste:

  1. Create a New Untitled document
  2. Create a new layer, Layer 1. No not assign any attributes to that layer
  3. Create a new layer, Layer 2 and assign a Layer Color Attribute of red
  4. Draw a Line on Layer 1
  5. Select the line in step 4 and choose Edit menu > Cut
  6. Make Layer 2 active and choose Edit menu > Paste
  7. Observe: The Line does adopt the red Layer Color Attribute assigned to Layer 2
  8. This is a correct result, the Line changed color

Work Arounds

Unfortunately, even forcing a redraw (pressing the 0 (that's zero) key) doesn't force the object to adopt the correct layer color if the Move to Layer command was used. The best method is to use Cut or Copy and Paste or Paste Special to move the objects between layers if the destination layer uses a Layer Color Attribute.

The issue has been reported to Engineered Software for action.

We hope that helps
caddpower.com

------
If you found this article or the website in general to be helpful, educational or a time and money saver you can show your support. Thank you ~ Brian (huc) Huculak

No votes yet

FIXED in PowerCADD 7.0.3

This condition is fixed with PowerCADD 7.0.3 which is a free update from Engineered Software XTNL URL in the United States or your local PowerCADD Distributor for International Users XTNL URL

problem still exists in 7.02

our current testing indicated the update to PowerCADD 7.02 does not fix this issue

if we have any additional information we'll post a comment

if you have any additional insights or information please feel free to post a comment here.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.